Avada Forums Community Forum YouTube background video will not Autoplay in Container or Fusion Slider

Viewing 15 posts - 1 through 15 (of 24 total)
  • Author
    Posts
  • inyerface
    Participant
    Post count: 2

    Everything is fine until autoplay is selected, then it does not autoplay. If you are using Fusion builder to play YouTube videos as a background, then in order for autoplay to function, mute must be turned on but then you can’t here the music.

    dugdaledesigns
    Participant
    Post count: 2

    I am having the same problem, I have a video that I want to autoplay on page load and it only works if the video is muted, if I set it not to be muted it won’t autoplay

    bjjohn22
    Participant
    Post count: 2

    I’ll do you one better…I have the slide settings on a Fusion Slider YouTube video set to “Autoplay Video – Yes”, “Mute Video – Yes” and “Hide Video Controls – Yes” and the video will not autoplay. I tried the same on a Vimeo video…same result. I’ve created a support ticket and was told to set the “Mute Video” setting to “yes” which it is already. I responded to the support ticket that this is not the issue and as of yet, I haven’t heard anything back yet. If I do, I will post my result here.

    litkai
    Participant
    Post count: 4

    Hi,

    I have the very same problem.
    This causes some JS errors:

    Uncaught TypeError: Cannot read property 'undefined' of undefined
        at playVideoAndPauseOthers (fusion-video-general.js:1)
        at Object.start (avada-fusion-slider.js:1)
        at jquery.flexslider.js:1

    Looking forward to any solution.

    Michael C
    Keymaster
    Post count: 538

    There are a few different possibilities here, so all the issues in this thread are unlucky to be the same.
    1. Videos need to be muted in order to autoplay. This is due to changes in browsers which prevent autoplaying videos with sound. Also some devices do not allow autoplaying at all.
    2. Ensure you have the necessary API turned on in Theme Options > Advanced (Vimeo/YouTube).
    3. Ensure you are on the latest version. That particular error you are referencing @litkai looks most likely to be a timing issue due to older theme version or extra caching. Could also be due to #2.
    4. As always check plugins and cache. In particular if you have Rocket Loader from CloudFlare it will lead to intermittent JS problems.

    litkai
    Participant
    Post count: 4

    Many thanks Michael C!

    Enabling the Youtube API and Purging the cache solved the issue. (autoplay & mute without error message)

    PondBoss
    Participant
    Post count: 1

    OK, so I started with the Avada Law theme, and I want to change the video to a youtube video…. but it won’t autoplay. I have that option and the mute option selected… what next?

    bjjohn22
    Participant
    Post count: 2

    I had the same problem. Make sure your Youtube and Vimeo API scripts are set to “on” in theme options.
    You can get to them in the Dashboard under Avada > Theme Options > Advanced > Theme Features.

    Hope this helps.

    acmel
    Participant
    Post count: 15

    I have the same problem and I solved it. I was adding the ID from the URL but that is incorrect. Go to your video on Youtube and then press “share”. You will see your ID without the Youtube part 🙂

    GVL06
    Participant
    Post count: 1

    Hello,
    I have the same problem.
    1. Videos need to be muted in order to autoplay. : OK
    2. Ensure you have the necessary API turned on in Theme Options > Advanced (Vimeo/YouTube). OK
    3. Ensure you are on the latest version. OK
    4. As always check plugins and cache. OK

    But after all, the problem remains the same : the youtube video in fusion slider not autoplay on mobile device

    Thanks for your answer

    Gil

    zayas
    Participant
    Post count: 1

    Hello!
    I have the same problem, no autoplay in desktop, i use cloudflare and i try all the different possibilities.

    Any answer?

    Thanks!

    satraptech
    Participant
    Post count: 3

    Android and iOS do not allow auto play for video backgrounds, this has nothing to do with Avada.

    However there should be an option in the theme for setting a static image instead video background for mobile, also in slider.

    MOW
    Participant
    Post count: 1

    Hey,

    I’m running into the same issue: self-hosted video as background in fusion slider fine on PC, not working on mobile.
    Ok, I put the same video to Vimeo –> still fine on PC, no autorun on mobile.

    I got what satraptech said about iOS and Android not allowing autoplay videos but then I found this: https://themes.develoved.com/uxshop-fashion/ and the second slide is an autoplay video that works very fine on my mobile.

    Are there any more ideas?
    Thanks a lot guys!

    Edd92
    Participant
    Post count: 1

    I have this problem too,
    No matter the settings, the video in the fusion Slider will not autoplay.

    When opening inspect tools i found the youtube URL. after playing around with the URL i found out that the URL does not contain the following parameters. Yes even when i had these settings to “yes” and cache cleared.

    &mute=1&autoplay=1

    If you add these to the URL, it will work. Imo this is a fusion bug that has to be fixed by Avada devs.
    Until this fix is implemented and you have updated, there is no way you can autoplay youtube videos in fusion silder.

    I created an support ticket, and i hope they will come with a workaround in the mean time.

    lsane
    Participant
    Post count: 1

    Hello,
    I have the same problem. desktop version running.. but mobile version not auto start youtube video

    what can i do ? i dont know

    help please

Viewing 15 posts - 1 through 15 (of 24 total)
  • You must be logged in to reply to this topic.