Home Forums Community Forum You Have d% Items In Your Cart / cant translate this

Only users with a registered purchase of Avada can post to the community forum. Please register your purchase here.

Tagged: ,

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • RemaN
    Participant
    Post count: 2

    Hi Guys,

    i have updated my site. Now I have the problem if there are more than two items in my cart. He does not translate the following part into German for me.

    “You Have D% Items In Your Cart”

    All texts have already been adapted via Loco Translate.

    Best regards
    Christian

    RemaN
    Participant
    Post count: 2

    bump

    AppelenEelman
    Participant
    Post count: 1

    I had the same issue for dutch language, it seemed in PoEdit that the strings for single product or multiple products were the same. When edited (in POedit Avada theme localization file) to different strings the translation worked.

    Michael C
    Keymaster
    Post count: 363

    For this, please ensure you have the most up-to-date language files. Then within the files you should only see 1 string, but with a plural option. For example:

    translation

    The old method had separate strings (incorrect) the method nowadays uses plural definition. For more details you can also check though the thread on the localization repo here – https://github.com/Theme-Fusion/Localization-l10n/issues/76

    acj
    Participant
    Post count: 2

    Hi, I have the same problem with a Dutch webshop I’m setting up. I got the latest translation files from GitHub, and uploaded them to the production server like this:

    • fusion-builder-nl_NL.mo, fusion-builder-nl_NL.po, fusion-core-nl_NL.mo, and fusion-core-nl_NL.po to wp-content/languages/plugins/.
    • Avada-nl_NL.mo and Avada-nl_NL.po to wp-content/languages/themes/
    • Avada.pot to /wp-content/themes/Avada/languages/

    However, I do not see any changes on the front of the website. Texts that were already translated correctly still are, but translations that have been missing still appear to be missing.

    Does it matter that I’m using a child theme? Any help would be appreciated.

    acj
    Participant
    Post count: 2

    Hmm. There appeared to be problems with the Avada translation files.

    I forked the repository, fixed this translation, and fixed and added several others. I opened a pull request which I suggest you review and merge: https://github.com/Theme-Fusion/Localization-l10n/pull/82.

    Cheers.

    stefaeva
    Participant
    Post count: 2

    I have the most up-to-date language files and followed all instructions in Avada guide. I cleared all the cache! But i continue to see the english sentence and not the italian translation. How can i solve it? What i have to check?
    https://www.extravergineorsini.it/vendita-diretta-olio-extravergine-di-oliva-biologico/ and then try to add a product: it still appears “You have … product in your cart”. Thank’s for any help!

    Michael C
    Keymaster
    Post count: 363

    Hi, please check my responses here – https://github.com/Theme-Fusion/Localization-l10n/issues/90

    Some of the language files may have an incorrect translation added, so will need updated. In particular check that the %s and %d properly match between the original and the translated strings.

    stefaeva
    Participant
    Post count: 2

    [SOLVED] Sorry for my stupidity Michael C. After updating the translations, I uploaded only the .po file. When i uploaded also the .mo file everithing is OK! Great AVADA and all the staff 🙂

Viewing 9 posts - 1 through 9 (of 9 total)
Only users with a registered purchase of Avada can post to the community forum. Please register your purchase here.