Avada Forums Community Forum When inserting a LINK to one of my web pages in an email, image is grayed out

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • Carolyn_
    Participant
    Post count: 6

    Here is an image of my problem: https://baytarrahmah.org/image/embedded-links-in-email_no-image.jpg

    When I send an email and insert a link (for example: https://baytarrahmah.org/2015_08_30_historic-nahdlatul-ulama-congress/) to a web page on my website, the image box that appears directly under the link is gray — in other words, no image is displayed.

    However, as you can see from the linked image above, when I insert links to other website pages in an email (for example: https://www.telegraph.co.uk/news/2019/05/16/government-absolutely-right-reject-flawed-definition-islamophobia/), an image from the web page does appear in the box beneath the link.

    My boss wants me to fix this, so that an image (from the web page) automatically appears in the box below the inserted link. How in the world do I get an image to appear? I have no idea how to fix it or what this problem is even called.

    Does anyone have the solution? I am not a software developer.

    Thank you,
    Carolyn

    marklchaves
    Participant
    Post count: 873

    Hi Carolyn,

    I’m not an expert on this, but I think your email client/app (from your screen capture) is pulling in Open Graph data to display a preview image and title/description snippet.

    You can define Open Graph settings with Yoast. https://yoast.com/advanced-technical-seo-social-image-ogimage-tags/

    Or, you can set your page’s feature image to the image you want displayed in the preview. Then view the source of that page to see if your og:image tag was set properly. Right now, here is what is in your og:image tag for the page you want to email.

    <meta property="og:image" content="http://baytarrahmah.org/wp-content/uploads/2018/01/bar-header-logo1_345x70.png"/>

    This is your logo. If your feature image is not set, usually the first image will be used as the default. And, that’s probably your logo.

    Here’s what’s defined in the Telegraph’s page.

    <meta property="og:image" content="https://www.telegraph.co.uk/content/dam/news/2017/11/29/muslims-xlarge_trans_NvBQzQNjv4BqZgEkZX3M936N5BQK4Va8RWtT0gK_6EfZT336f62EI5U.jpg">

    That’s the same image that’s showing up in the Telegraph’s preview.

    You can compare the other associated og tags and see they should match what’s in the snippets.

    BTW, the URL in your og:image tag starts with http. This might be an issue too. It should be https and this works fine when you copy/paste the URL using https instead into the browser. I checked.

    Hope that helps 🙂

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.