Avada Forums Community Forum Using Layout Templates with WPML

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • Joe
    Participant
    Post count: 6

    Hi,

    Not sure if I am doing something wrong here, but I am trying to setup our site using the Avada Layouts tool introduced in 7.0. However, I am running into an issue where I can’t get the layouts to play nice with WPML.

    So, I want the use the layouts to create a new header for our site. The header therefore needs to appear on every page/post/faq etc. on our site, basically any and all content should show the header, therefore it makes more sense to use the Global header option, rather than a custom layout, where I would have to go through each section and enable the layout for everywhere.

    However, if I create a global header using our English US site, then switch over to the English GB site, I am unable to create a GB variant of the header called ‘Header GB’, it simply refreshes the global layouts list, but remains empty, but then if I switch back to the US language, I can see it has updated the global header with ‘Header GB’. So, there seems to be no way to create a unique header, which is global across a language, without using a custom layout instead.

    Is this right? Or am I missing something? If I have to use the custom layouts, then fine. My concern is that a new content type or something will be added to the site down the line, and won’t show the new header unless someone specifically remembers that they need to enable the header on that content type.

    gustaflindqvist
    Participant
    Post count: 1

    We have the same issue with 7.2.1, but with Avada and Polylang. The site was upgraded from 7.0.2 and now the global layout isn’t working as intended.

    There have been some major changes for both WPML and Polylang in version 7.1 of Avada. So the only option is to downgrade again to Avada 7.0.2.

    websanityweb
    Participant
    Post count: 8

    Has anybody got a hack for working around this? I am using Polylang latest and Avada latest. Like the original poster I can’t set a global header.

    But neither can I set more than one header. If I set a header for GB then US is blank. If I set one for US it DELETES the UK one, and so on in a viscous circle.

    It is, unfortunately, unusable in this state if you want to use Page Layouts and a language tool with Avada.

    EDIT: I have raised a support ticket so will post back here when I get a response.

    CYTYIT
    Participant
    Post count: 1

    Hi,

    Do you have any news about this issue?

    Same issue with Avada 7.4.2 and Polylang 3.1.1

    benjaminblue
    Participant
    Post count: 36

    I am having the same issues with Polylang and the Avada Layouts – has anyone got that working?

    SandraGie
    Participant
    Post count: 2

    Same problem here. Also using Polylang and it is not changing to the new layout I made for blog posts.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.