Home Forums Community Forum Unable to hide a container

Only users with a registered purchase of Avada can post to the community forum. Please register your purchase here.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • Shadowforgedesign
    Participant
    Post count: 1

    I’ve been trying to hide a container that’s been showing up as white space at the bottom of my page.

    I’ve tried toggling the visibility on small/medium/large screen but nothing happens when I turn all three off.

    There used to be something you could put in the CSS class to hide it but I can’t remember what it was. I think it was fusion-hidden or something alike.

    revans0636
    Participant
    Post count: 55

    The CSS Class fusion-hidden still seems to be working. ūüôā Did you try testing that CSS class setting with another container on your page? Also testing by changing the container’s BG color?

    Are you sure it’s the container, and not the footer’s top padding? There’s a Setting for Footer padding in Avada>Theme Options>Footer>Footer Styling for the padding – try setting the top padding to 0px. (You can also use the footer styling to change the background color of the footer to help you pinpoint what’s causing the gap.)

    mads sonne
    Participant
    Post count: 5

    It might also be something as simple as the column margin. By default it is set to 0px, 20px (top, bottom).

    You can change the default settings here: Avada>Theme Options>Fusion Builder Elements>Column Element>Column Margins

    You can also adjust the margin for each individual column: Click on the pen icon for that specific column>Design>Margin
    So if you adjust the margins for the bottommost column(s) and set them to 0px, 0px, your problem might be solved.

    philipbutlerfreelance
    Participant
    Post count: 3

    if you want the container to be hidden for visitors who are not logged in, add the class name ‘hide’ to a container then declare the following in the custom CSS. The container will still be visible if you are logged in. I find this handy while developing a live site.

    .hide {
        display:none;
    }
    .logged-in .hide {
        display:block;
    }
    Michael C
    Keymaster
    Post count: 322

    Depending on which form of hiding you need we have also added publish options to the container. This allows the container to be excluded from the page entirely (for logged out users). For more details you can check out the documentation at https://theme-fusion.com/documentation/fusion-builder/elements/container-element/ (Container Publishing Status section).

    si0077
    Participant
    Post count: 1

    I can’t seem to get this to work. I need to hide containers for logged in users. My homepage needs to display different content for logged in users. Can anyone please help?
    Thank you.
    Simon.

    Michael
    Keymaster
    Post count: 445

    Hi @si0077

    You have active theme support and because our support team does not provide support via the community forum, please create a ticket using the link below and our team will gladly help going forward.

    Click Here To Get Avada Support

    We look forward to helping you!

    Thank you kindly

Viewing 7 posts - 1 through 7 (of 7 total)
Only users with a registered purchase of Avada can post to the community forum. Please register your purchase here.