Home Forums Community Forum Site no longer works after updating to PHP 8.0

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • ImpetuousRacer
    Participant
    Post count: 3

    After updating to PHP 8.0, I go to my website and receive the error “There has been a critical error on this website.” I’m on the most current version 7.3 of Avada.

    Reverting to PHP version 7.4 and it works normal again.

    I disabled all plugins while on PHP 7.4 except for Avada Builder and Avada Core, and try to update to PHP 8.0 and still receive the same error.

    When updating to PHP 8.0, there are a multitude of items checked and some unchecked, such as the following being unchecked:
    calendar
    nd_mysqli
    nd_pdo_mysql
    opcache
    pdo_mysql
    snmp
    sodium

    Should any of those be enabled? Or any that I have enabled that should not be?
    How can I trace what is causing the issue? Thanks for the help!

    Ammar. S
    Keymaster
    Post count: 1639

    Hello @ImpetuousRacer

    Avada works all fine and good on version 8.0 of PHP in this case if you are seeing any issues, please try enabling the wp_debug() and check again once, if the issue persists please send us an email to support@theme-fusion.com and we will further check this out.

    Thanks

    -Ammar

    ImpetuousRacer
    Participant
    Post count: 3

    I enabled debug..

    Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /home/sitefolder/public_html/wp-includes/wp-db.php:1685 Stack trace: #0 /home/sitefolder/public_html/wp-includes/wp-db.php(632): wpdb->db_connect() #1 /home/sitefolder/public_html/wp-includes/load.php(545): wpdb->__construct(‘sitefolder_wp618′, ‘5NS](2e5Mp’, ‘sitefolder_wp618′, ‘localhost’) #2 /home/sitefolder/public_html/wp-settings.php(124): require_wp_db() #3 /home/sitefolder/public_html/wp-config.php(90): require_once(‘/home/sitefolder/…’) #4 /home/sitefolder/public_html/wp-load.php(37): require_once(‘/home/sitefolder/…’) #5 /home/sitefolder/public_html/wp-blog-header.php(13): require_once(‘/home/sitefolder/…’) #6 /home/sitefolder/public_html/index.php(17): require(‘/home/sitefolder/…’) #7 {main} thrown in /home/sitefolder/public_html/wp-includes/wp-db.php on line 1685

    ImpetuousRacer
    Participant
    Post count: 3

    Thanks, the debugging helped me trace the error. I’m using PHP Selector in the cpanel for a2hosting.
    Looks like 7.4 was using nd_mysqli and when going to PHP 8.0, it changed that to mysqli.
    I unchecked mysqli and enabled nd_mysqli and it is working again. Appreciate the help.

    Ammar. S
    Keymaster
    Post count: 1639

    Hello There

    Glad to hear you are all set now 🙂
    have a good weekend!

    -Ammar

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.