Avada Forums Community Forum PHP 7.4 Support

Tagged: 

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • DarkAllMan
    Participant
    Post count: 67

    I just tested PHP 7.4 on my dev site. It seems that Avada is not yet compatible.
    When can we expect Support?

    DarkAllMan
    Participant
    Post count: 67

    Deprecated: array_key_exists(): Using array_key_exists() on objects is deprecated. Use isset() or property_exists() instead in /wp-content/plugins/fusion-builder/inc/helpers.php on line 242

    Ammar. S
    Keymaster
    Post count: 2234

    Hello @DarkAllMan

    As PHP 7.4 was released just week ago, our developers have an item about this and we will be running a complete compatibility check to see what changes are required.

    Thanks

    -Ammar

    DarkAllMan
    Participant
    Post count: 67

    Excellent!

    Jetxpert-Envato
    Blocked
    Post count: 339

    @darkallman,

    Are you having any specific issues with Avada using PHP 7.4?

    We started using PHP 7.4 last week with no apparent issues. In fact, our website is running faster!

    Cheers!

    DarkAllMan
    Participant
    Post count: 67

    I ran it on my dev site, with debug mode on, and the first 200 lines where notices 🙂

    Jetxpert-Envato
    Blocked
    Post count: 339

    @darkallman,

    It appears Avada is going to address your issue. However, did you perform the usual troubleshooting tests?

    1. All plugins disabled
    2. Switch to lower PHP version
    3. Switch to another theme? (e.g., Twenty Twenty) (THIS ONE IS KEY)

    At our end, we see no apparent issues with PHP 7.4. However, we certainly hope the developers of Avada are taking advantage of PHP 7.4 to make the theme run faster, more efficiently. I’m quite certain they are.

    Cheers!

    thevoice2010
    Participant
    Post count: 1

    Any status/ETA updates on Avada patching/upgrades? I can’t seem to successfully run Avada while 6.1.2 running PHP 7.4 without bricking the site with a Fatal Error.

    I uploaded the theme (deleted WP default themes), activate Avada, install/activate Fusion Builder, install/activate Fusion Core, and apply any recent patches. And when I refresh to the root domain —— Critical Error. Error self-corrects when I downgrade PHP to 7.3.

    Really would like to take my site to the next leve of performance – but I’m not sure that there’s much I can do at this point. 😔

    Thoughts?

    Ammar. S
    Keymaster
    Post count: 2234

    Hello @thevoice2010

    We do not have any reports of FATAL error on 7.4 version of PHP for sure, there are only some notices that will be taken care of in our next update, however if you are seeing a FATAL error make sure its not due to any 3rd party plugin or some other PHP limit, also you do have a GrandFathered Support so please open a support ticket with our team in this case and we will check this out for you right away.

    As the Themeforest comments section is meant only for pre-sale questions and generalities, we are not able to provide detailed support here. Please create a support ticket using the link below and our support team will gladly assist and guide you

    Click Here To Create An Account & Get Avada Support

    Thanks

    -Ammar

    Richard_uk77
    Participant
    Post count: 9

    ive had the same issue? Tried this for siteground website that we have, it would not work for 7.4.1 …..

    Jetxpert-Envato
    Blocked
    Post count: 339

    @Richard_uk77,

    We have a website hosted by SiteGround and are also using PHP 7.4.1. No issues.

    Most likely, your issue(s) are due to a plugin conflict or an Avada theme setting that’s triggering the error. Did you test your website with all plugins deactivated? Also, plugin below may help you troubleshoot and identify the root cause of your issue(s).

    Query Monitor

    Cheers!

    Richard_uk77
    Participant
    Post count: 9

    Hi jetxpert-envato

    i did get a direct ticket from avada support, i did get this “Actually latest version of Avada 6.1.2 is not fully compatible with PHP 7.4 and those issues you have brought up relates to PHP 7.4. Our upcoming version of Avada 6.2 covers it and have full compatibility.

    So it is already fixed by our developers in Avada 6.2 and we’re expecting the release of Avada 6.2 somewhere in start of next month but we don’t have any exact date right now. Its recommended to use PHP 7.3 until we release our Avada 6.2 version.”

    So for now, im going to leave for 7.3. The errors only came up in the admin area in the Avada theme options selector, and when trying to edit pages/posts.

    crcc23
    Participant
    Post count: 1

    After I update the site from 7.3 to 7.4 or 7.4.1 all the areas where I use the fusion builder to create content are just blank!

    What could be happening. I try this updates in a few sites and it happened to me in some of them.

    Thanks!

    Metro
    Participant
    Post count: 116

    Make sure the same PHP extensions are enabled. We are now running PHP 8.0 without any issues.

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.