Avada Forums Community Forum IMPORTANT NOTE: JS Compiler is disabled. File does not exist or access is restri

Viewing 15 posts - 1 through 15 (of 21 total)
  • Author
    Posts
  • Lammworks
    Participant
    Post count: 1

    Hi all,

    Does anyone knows where this files are located? I am certain this is a security or server (nginx) configuration issue. But i first need to figure out where to look.

    Any clues?

    Michael C
    Keymaster
    Post count: 538

    The files are stored in /wp-content/uploads/fusion-scripts/. It is possible that your server prevents JS files from being added there, or the wp uploads folder has been changed/corrupted.

    However, before doing that, try enabling the option and checking if the file is created and option stays on. It is possible the error is just showing from previous problems and if re-enabled will work. If the options disables itself next time you come back or file is not created then you will know that it is a permissions issue.

    revans0636
    Participant
    Post count: 69

    After you’ve enabled the option and saved the setting, be sure you exit the admin area and visit your site from the front end as a surfer (so the fusion-scripts folder/files are regenerated – site traffic to the page content triggers their creation) then go back to the WP dashboard and check (or check for the folder with FTP).

    Resetting the Fusion cache from the theme options or installing a theme update deletes all of the fusion folders as part of the housekeeping routine.

    Tizar
    Participant
    Post count: 1

    Hi!

    Faced the same problem. Turn on the option, open the site, go back to the admin panel, the option is off. Permissions on directories is 755, the folder “uploads” not changed.
    File *.min.js is generated, but for some reason does not work

    Michael
    Keymaster
    Post count: 715

    Hi @Tizar

    In that case please do create a support ticket and our team will gladly check your install and assist you with this. Please do note, you have valid and active Avada Grandfathered support as explained here -> http://bit.ly/2J3dQw2

    Thank you kindly

    log4en
    Participant
    Post count: 8

    I’ve the exact same problem with last version of Avada 5.6 and SiteGround. Any suggestion?

    log4en
    Participant
    Post count: 8

    No suggestion I think. I’ve the same problem on all my sites hosted with SiteGround

    Inner-Tree
    Participant
    Post count: 1

    Same problem here. There is no generation of any .js file.
    Followed the steps above; meaning;
    set Enable JS Compiler > OFF and cleared cache
    closed window of Admin
    created folders fusion-scripts and fusion styles in ~/wp-content/uploads
    The folder /uploads has permissions 755
    Opened the page from user perspective in another browser, went along al menu options.
    Folder fusion-scripts gets not populated. There is no generation of any .js file. Fusion-styles does get populated.
    Returned to (the other browser) admin and set JS Compiler > ON.
    Error message re-appears.
    Site is http://test.inner-tree.com

    Please help?

    Michael C
    Keymaster
    Post count: 538

    Hi @Inner-Tree,

    According to our records you still have active support. If you would like support please fill out the ticket submission form – https://theme-fusion.com/support/submit-a-ticket/.

    Note, the website you have posted is already running the JS compiler, so it would seem this has already been resolved.

    josefhaydn
    Participant
    Post count: 1

    Is there any solution known for this problem yet?
    I have exactly the same problem. It appeared in 5.4 and continues to
    be a problem in 5.6.2.
    JS compile option can be selected, but after re-login it is
    normally gone again. The error message is the same as mentioned above.
    It definitely is not a server problem. I can set my permissions manually
    in the shell, I am running a Linux server. The whole subdirectory of WP
    has full permissions and permissions have never been a problem before.
    The same problem also exists in xampp on Windows.

    My situation is this: Multisite installation, 2 subsites.
    Avada creates the necessary direcories with minified CSS and JS.
    But after re-login the files and corresponding directories are simply
    deleted.

    I would be grateful for a solution and am wondering why not more
    customers are experiencing this. Maybe it only happens with WP multisite
    installations? AFAIK the problem has not been here before 5.4 but this
    could be a coincidence since I changed to WP multisite when I updated to
    5.4.

    Mohammedays
    Participant
    Post count: 22

    i have the same issue, please help

    Michael
    Keymaster
    Post count: 715

    Hi @josefhaydn

    Are you running one or more cache plugins and enabling the JS compiler? This was the case with @Inner-tree when checked by our team. Having multiple cache resources running can lead to issues like this.

    Please send your URL, WP Admin and FTP info to support@theme-fusion.com and we will check your install for you. In the body of the email please include the link to this community forum thread.

    Thank you kindly

    gilesbutler
    Participant
    Post count: 1

    We had the same issue and contacted the support guys.

    Add the following to the bottom of your functions.php…

    add_filter( 'fusion_compiler_js_file_is_readable', '__return_true' );

    This worked for us.

    Not sure if it’s related though but CSS file compilation isn’t working anymore.

    Jollaman
    Participant
    Post count: 1

    @gilesbutler thanks! Your fix worked for us also.

    We have WP Fastest Cache as a caching system. For anybody of you that might need it, that’s what we did:
    – Add add_filter( 'fusion_compiler_js_file_is_readable', '__return_true' ); to our functions.php
    – Disable WPFC cache and clear its cache
    – Enable JS Compiler and clear its cache
    – Enable again WPFC cache and clear its cache

    Works perfectly and faster than before.

    log4en
    Participant
    Post count: 8

    works for me 🙂

    add_filter( ‘fusion_compiler_js_file_is_readable’, ‘__return_true’ );

Viewing 15 posts - 1 through 15 (of 21 total)
  • You must be logged in to reply to this topic.