Avada Forums Community Forum Images appear in preview but not on Internet

Tagged: 

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • jgarv
    Participant
    Post count: 4

    Avada 7.8. I am trying to display four images side by side in a post. I have tried Gallery and Image Carousel. In both cases they display perfectly when I preview the post, but not on the Internet. I have tried both Firefox and Brave.

    Any advice greatly appreciated!

    Thanks.

    Jim

    revans0636
    Participant
    Post count: 69

    If you have a cache plugin or hosting-provided cache like SiteGround’s Optimizer plugin. flush the cache and then try it with your cache disabled.

    Ray

    jgarv
    Participant
    Post count: 4

    Thanks Ray, but I don’t have SiteGround or any other plugin that seems to have anything to do with a cache. I have flushed the main WordPress cache (twice) but to no avail.

    Should I disable the WordPress cache, if that’s even possible?

    revans0636
    Participant
    Post count: 69

    So much for the easy fix. We hit that issue with Avada v7.6.2 – pages looked great when previewed, but images didn’t display on web check. Turning off the SG image optimization got the pics back, but then the sites were too slow on PageSpeed testing – average on desktop and terrible on mobile.

    Do you use any 3rd party plugin for image optimization/image format conversion (like Smush, ShortPixel, or something along those lines)?

    Did you use the Firefox code inspector Console or just view the page in your browsers? Dev tools Console might help you get a direction to pin down what’s causing the issue, then go from there.

    The next step would be to disable all of your plugins, then reactivate Avada Core and Avada Builder, log out of WP, clear your browser cache, and then retest the page(s) you’re having a problem with. Checking for plugin conflict would be my next step.

    The best suggestion would be if you have active support would be to submit a support request. That’s usually the fastest way when you hit something like this. If you don’t have that option, post a URL

    Note: wouldn’t recommend disabling the WP cache. If anything do a manual purge (but don’t think that will help you on this one).

    Ray

    • This reply was modified 3 weeks, 2 days ago by revans0636.
    jgarv
    Participant
    Post count: 4

    Thanks for your continued assistance, Ray. I don’t have any image optimization plugins, to the best of my knowledge. But I tried your suggestion of disabling all plugins and the rest of your instructions, but it made no difference.

    I had been just viewing the page in my browsers, but at your suggestion I tried Firefox Browser Console, with this result:

    Error: Warning processing windowTypes: This property is deprecated global.min.js:250
    Promise rejected after context unloaded: Actor ‘Conduits’ destroyed before query ‘RuntimeMessage’ was resolved
    scan.js:38

    Doesn’t mean anything to me; hopefully it will give you a clue.

    revans0636
    Participant
    Post count: 69

    Sadly, not enough of a clue to help with a why, or more importantly a fix for you. Maybe someone else will see/respond with a suggestion? At this point, the best suggestion I can offer is to submit a support ticket.

    Ray

    jgarv
    Participant
    Post count: 4

    I see my active support has expired. Guess I should renew! Thanks for all your help, Ray.

    Jim

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.