Avada Forums Community Forum image title appears on image hover – how to disable it?

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • wolverinejoe80
    Participant
    Post count: 17

    I’m getting instances where image names appear if you hover over the photo. and this only happens when i add image via builder elements. this doesn’t happen when i just ‘add media’ in text block.

    Is there any way to prevent this from happening anywhere…forever?

    wolverinejoe80
    Participant
    Post count: 17

    i know if i delete the title from media then it won’t show. but i need titles for SEO purpose.

    hawea74
    Participant
    Post count: 6

    Try this:

    Go to Avada > Theme Options > Advanced > Code Fields

    add the below code in the Space before </head> field

    <script>jQuery(document).ready(function($) {
    $(‘img[title]’).each(function() { $(this).removeAttr(‘title’); });
    });</script>

    This worked for me to disable image titles on hover, without having to remove them in Media.

    NickWingfield
    Participant
    Post count: 2

    Brilliant! Thanks Hawea74

    Just one thing, though. Didn’t work at first for me. Then I discovered that when I copied and pasted your code it made the inverted commas curly (like filled in number nines). So I deleted them and re-typed them to get straight inverted commas. That worked!

    Much appreciated

    Nick.

    hawea74
    Participant
    Post count: 6

    Good to hear Nick. Yes, I often get that same character thing from a copy-paste which is resolved by re-typing.
    Regards, David

    vdvwebdesign
    Participant
    Post count: 2

    Im looking for this for a long time! I paste the code into Go to Avada > Theme Options > Advanced > Code Fields. It doesnt work 🙁

    What is wrong with the code? Can u post the good one, with good commas?

    Thanks in advance!!

    hawea74
    Participant
    Post count: 6

    Hi vdvwebdesign,

    This code works for me:

    <script>jQuery(document).ready(function($) {
    $(‘img[title]’).each(function() { $(this).removeAttr(‘title’); });
    });</script>

    Try re-typing the wrapping inverted commas in your own plain text editor – these ones:
    ‘img[title]’
    ‘title’

    Read Nick’s response above and how he got the code to work for him.

    Good luck 🙂

    atulcj
    Participant
    Post count: 1

    Thank You @hawea74 for this solution. Found your answer after nearly 5 hours of searching through Avada documentation, google, Avada Facebook group.

    hawea74
    Participant
    Post count: 6

    @atulcj you’re welcome, glad you found it helpful 🙂

    rstander
    Participant
    Post count: 1

    Thank you for this! Exactly what I needed and worked perfectly with re-typed inverted commas.

    clintwesly
    Participant
    Post count: 1

    Perfect! Worked exactly like described once the apostrophes (inverted commas) were changed.

    Ammar. S
    Keymaster
    Post count: 2421

    Hello @hawea74

    Thanks for helping out fellow community members 🙂

    -Ammar

    agathonienne
    Participant
    Post count: 1

    Works great thanks !

    synchronicity
    Participant
    Post count: 1

    Not working for me, I rewrote the –> ‘ <– (inverted commas, we call them apostrophes) and did not work either. I’m using Avada 7.3.

    This should be an option in the global theme 🙁

    stanleyg95
    Participant
    Post count: 4

    didn’t work for me! any other options?

Viewing 15 posts - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.