Avada Forums Community Forum Iframe on fusion builder "Code block" ?

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • partenairemicro
    Participant
    Post count: 5

    Hello,

    When I insert the following code in “code block”, it does not work, an idea?

    <iframe width="600" height="850" src="https://xxx.yyy.zz/" frameborder="0" allowfullscreen></iframe>

    Thanking you,

    FA.

    Michael C
    Keymaster
    Post count: 540

    Hi @partenairemicro,

    What exactly happens when you add that code? Note, if using the code block, please ensure that code block encoding is turned on in the Theme Options. If not WordPress default editor can alter your code and therefore break it.

    partenairemicro
    Participant
    Post count: 5

    Hello Michael,

    I get a blank page.

    Nothing appears on the page.

    But for example, if I test the url directly (src = “”) the form is displayed correctly.

    Michael C
    Keymaster
    Post count: 540

    Hi, I am afraid more information would be necessary to tell the problem. It could very well just be that cross origin policy is blocking the iframe. If you open up developer tools in the browser there will be a message about that if it is the case (right click and select inspect if using Chrome).

    Alternative if you post a link to your site I should be able to tell you the problem.

    partenairemicro
    Participant
    Post count: 5

    Michael,

    In inspect on chrome :

    Refused to display ‘https://xxx.yyy.zz/&#8217; in a frame because it set ‘X-Frame-Options’ to ‘sameorigin’.

    partenairemicro
    Participant
    Post count: 5

    In my ngnix : add_header X-Frame-Options SAMEORIGIN;

    Michael C
    Keymaster
    Post count: 540

    Hi,

    That makes sense. If you Google that general error you will find information about how to resolve that. Note the changes will be required to be made on the server from which you are trying to display (assuming it a website of your own and not another website which you have no control over).

    partenairemicro
    Participant
    Post count: 5

    It’s OK :

    add_header X-Frame-Options “ALLOW-FROM https://xxx.yyy.zz&#8221;;

    Thanks 🙂

    plxmas
    Participant
    Post count: 3

    I have the same problem.
    do you resolve it?

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.