Avada Forums Community Forum How to Disable / Remove icomoon.woff file

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • strollercritic
    Participant
    Post count: 4

    Having this file is making my sit load 6 seconds slower as you can see from the lighthouse test i ran on the screenshot link below:

    https://ibb.co/6bpXTZ4

    I am using the Pets theme. Is there a way to add preload to the import or somehow get rid of this?

    Anyone help, please!

    Shaminder
    Keymaster
    Post count: 154

    Hi

    If the theme is not Avada then I can suggest using a cache plugin. Certain cache plugins do have an option to do this


    Note that the Avada community forum is primarily for a user to user interaction.

    If you would like hands-on assistance here, please register for support and create a support ticket as explained here → https://theme-fusion.com/avada-doc/getting-started/avada-theme-support

    Thank you!

    Shaminder

    strollercritic
    Participant
    Post count: 4

    Hi, yes the theme is AVADA using the pet theme.

    I have the wordpress plugin autoptimize.

    Can’t get rid of this error at all

    websanityweb
    Participant
    Post count: 9

    I’m seeing the exact same issue in an Avada theme based website.

    Google speed test tool:
    Preload key requests
    6.48 s
    Consider using <link rel=preload> to prioritize fetching resources that are currently requested later in page load. Learn more.

    https://www.xyz.com/wp-content/themes/Avada/includes/lib/assets/fonts/icomoon/icomoon.woff

    Potential Savings: 6,480ms

    Site is using
    WP Optimize
    Autoptimize
    and plenty of Avaada performance settings tuned. But is not using any custom icons.

    Latest Avada version

    websanityweb
    Participant
    Post count: 9

    NOTE: ONLY shows the above in mobile analysis results, not desktop

    strollercritic
    Participant
    Post count: 4

    Tried all those plugins and settings and still can’t get rid of the error.

    It’s seriously affecting my performance score.

    How would you add preload to the import, you’d have to edit the core theme file, then when updates come through you could mess things up.

    So frustrating this.

    GetAutomated
    Participant
    Post count: 5

    I’m having this same issue, also for mobile only. Anyone have any further ideas or suggestions to fix this?

    omargamboa
    Participant
    Post count: 4

    Hi. I’m getting the same message from PageSpeed. Is there any way to fix it?

    I have the issue with
    icomoon.woff
    fa-solid-900.woff2

    omargamboa
    Participant
    Post count: 4

    Hi everyone. I got a solution from tech support:

    “To resolve this, please go to Dashboard -> Avada -> Options -> Performance section and set the CSS Compiler method to File and also set the Font Face Rendering to Swap All.”

    That’s it 🙂

    Pacey
    Participant
    Post count: 1

    Bump. I’m having the same issues. Tried the solution from omar with no luck.

    cormip
    Participant
    Post count: 3

    Avada now has a “Preload Key Fonts” setting under Options > Performance

    This solved the “Preload key requests” issue on both mobile and desktop for me.

    ridders999
    Participant
    Post count: 1

    I would wait to see if 7.4 properly addresses this as I can force it to preload fonts/icons but not disable them from being loaded again from the CSS (in 7.3)

    This is just what I have done in 7.3 which could be completely insignificant now.

    the icons are locally hosted certainly icomoon and font awesome is, I’m guessing most people are using google fonts either external calls or cached variants which presents an issue for preloading to a cached set of locals fonts if they ever getclearedrom the cache, so if you have made up your mind on fonts best to upload them manually before doing anything else.

    you can add code into your headers in the advanced tab in the style of

    <link rel=”preload” as=”font” href=”https://yourwebsite.com/pathtofontsoricons/yourfontoriconname.woff2&#8243; type=”font/woff2″ crossorigin=”anonymous”>
    could be woff2 , woff or whatever else you want to preload font wise.

    you can check this works on gtmetrix and see if the fonts are preloaded, if not you can try just crossorigin in that code above. there’s something with CORS which requires cross-origin but I forget the exact reason 🙂

    the only issue here is that even when the fonts are preloaded the big main CSS file will call them again so you load the same font twice, I’m really hoping 7.4 addresses this as I’ve wasted a lot of time trying to get it working correctly.

    bdooley
    Participant
    Post count: 1

    Even in 7.4, still getting this error despite these performance settings:
    Font Face Rendering: Swap All
    Preload Key Fonts: All
    CSS Compiling Method: File

    nfaulkner
    Participant
    Post count: 1

    Any updates on this? I’m running into the same issue where even with v7.4 “Preload Key Fonts” set to “all” I still seeing Google Page Speed Insights flagging various .woff2 files as “Preload key requests” opportunity. The woff2 files look to be called from the large computed fusion-styles CSS file.

    This is on a new build site where we are testing page speed as we go along. Caching rebuilt/disabled during all testing.

    charz
    Participant
    Post count: 2

    Hello Everyone!

    For me it works this way.
    Environments:
    – Lightsail AWS instance
    – Apache
    – WordPress 5.8.2

    Step 1: Enable .htaccess for Apache
    Access the console by ssh and open the file.
    `sudo nano /opt/bitnami/apps/wordpress/conf/httpd-app.conf
    Change AllowOverride None to AllowOverride All
    Save changes

    Step 2: Add the following code to the end of your .htaccess file

    <link rel="preload" as="font" href="https://YOURDOMAIN/wp-content/themes/Avada/includes/lib/assets/fonts/icomoon/icomoon.woff" type="font/woff" crossorigin="anonymous">
    
    Step 3: Restart Apache
    

    sudo /opt/bitnami/ctlscript.sh restart apache

    How to preload the font?

    In the parent template, in the header.php file it should be added just after the tag head.

    `<link rel=”preload” as=”font” href=”https://YOURDOMAIN/wp-content/themes/Avada/includes/lib/assets/fonts/icomoon/icomoon.woff&#8221; type=”font/woff” crossorigin=”anonymous”>

    Enjoy!

Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.