Avada Forums Community Forum How to control anchor text for SEO purposes, within blog feeds?

Tagged: 

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • sbell22
    Participant
    Post count: 1

    When running an evaluation of my site using SEMRush, all pages that pull in blog posts or related posts, or faq posts, show missing anchor text. This is anchor text as it relates to SEO in blog feeds, on a page where they are pulled in such as blastofflabs (dot com slash) frequently-asked-questions/

    These are links that are auto-generated, when we pull posts onto a page – so we don’t have direct control over the link structure. Avada is generating them.

    My question is – how do I resolve that error?

    Thanks in advance! —

    Steve

    mario.nee
    Participant
    Post count: 1

    I am also interested to this topic, any news?

    Jetxpert-Envato
    Blocked
    Post count: 339

    Good Day!

    Can you provide examples (screenshots) of what you’re experiencing? If so, please include both the webpage(s) in question and the associated SEMrush notices or warnings. Would be helpful.

    On the side, have you read this SEMrush blog? It may help solve your issue.

    With Avada, you should have full control of your anchor texts. We don’t have any issues. If the SEMrush notices or warnings are caused by external, improperly-labeled anchor texts, then it appears there’s not much you can do. Ignore them or change the structure of your content.

    Cheers!

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.