Home Forums Community Forum Google insights webfont load issue

Only users with a registered purchase of Avada can post to the community forum. Please register your purchase here.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • Salt-Media
    Participant
    Post count: 12

    Hi

    Im trying to fix the webfont load issue with Google insights. I use one Google font and two custom fonts in Avada theme.

    Am I correct in saying that the way Avada implements Google and custom fonts I can’t actually add the needed font-display: auto; CSS to combat the issue of fonts remaining visible during load?

    Michael C
    Keymaster
    Post count: 363

    Hi @salt-media

    In Avada 5.8 you will have the option of selecting font-display swap or block. So, if you want to improve performance you can select swap. Otherwise you can stick with block which is already the automatic functionality in browsers.

    Salt-Media
    Participant
    Post count: 12

    Hi Michael

    Thats good to know, any idea on release date?

    Thanks

    Michael C
    Keymaster
    Post count: 363

    Hi @salt-media, 5.8 is active just now (released yesterday/last night).

    hryksbt2003
    Participant
    Post count: 3

    I have changed to “swap”. But still facing to “Ensure text remains visible during webfont load”.
    How can I resolve this?
    Avada version is 5.9.1.

    cadream
    Participant
    Post count: 1

    Any update on this issue? I have the same problem even after switch to “swap”. version 6.0.1

    jeffnp
    Participant
    Post count: 12

    I just did a bunch of reading about this and my impression, though I’m not certain, is it’s a Google issue, not ours (or Avada’s). See https://github.com/GoogleChrome/lighthouse/issues/6628.

    In other words, it seems everyone has this issue, even if using “swap.”

Viewing 7 posts - 1 through 7 (of 7 total)
Only users with a registered purchase of Avada can post to the community forum. Please register your purchase here.