Avada Forums Community Forum GDPR Privacy consent breaks tracking code

Tagged: 

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • tom_aandewiel@hotmail.com
    Participant
    Post count: 2

    When enabling the privacy consent + bar , the tracking codes are placed in <noscript> tags inside the head. They look like:

    <noscript class=”fusion-hidden” data-privacy-script=”true” data-privacy-type=”tracking”> “tracking code”</noscript>

    When this is enabled browser extensions such as google tag assastant don’t spot any tracking codes anymore. Anoyone knows how to fix this?

    Thanks!

    Michael C
    Keymaster
    Post count: 549

    Hi Tom,

    This is the purpose of the privacy consents. It stops the tracking until consent has been given. If you do not wish this to happen then the tracking cookies in the privacy consents should be removed. That way it will load as normal.

    Note, you have grandfathered support. If you require further assistance you can open up a support ticket from – https://theme-fusion.com/support/submit-a-ticket/

    Thanks

    tom_aandewiel@hotmail.com
    Participant
    Post count: 2

    Thanks for the reply Michael. I understand that this is normal for when users do not give consent. However, what i described happens when i do have given consent. I can see the tracking code being inserted into the <head> but as a noscript with a string in it. This is not picked up by tag assistant or any google analytics tool. Can you explain why this happens? Because even with consent, the code thats inserted does not to seem to be working at all

    Michael C
    Keymaster
    Post count: 549

    Hi,

    If consent is given then the script will not be added as noscript. Also as soon as consent is given the noscript will be replaced. So as long as consent has already been given then the tracking should be working. Note, as I already mentioned – you have grandfathered support. So if you require assistance with this please open a ticket. We do not provide official support here on the community forum.

    If you still have noscript, chances are consent has not been given. In which case you most likely have the bar set up, but on initial acceptance click that will only dismiss the bar (depending on how you have set the Theme Options).

    mfuetterer
    Participant
    Post count: 20

    Same here.
    Even when consent is given, it is placed in <noscript> tags.

    <!– Global site tag (gtag.js) – Google Analytics –>
    <noscript class=”fusion-hidden” data-privacy-script=”true” data-privacy-type=”tracking” async data-privacy-src=”https://www.googletagmanager.com/gtag/js?id=G-DNW9C9CGVV”></noscript&gt;
    <noscript class=”fusion-hidden” data-privacy-script=”true” data-privacy-type=”tracking”>
    window.dataLayer = window.dataLayer || [];
    function gtag(){dataLayer.push(arguments);}
    gtag(‘js’, new Date());

    gtag(‘config’, ‘G-DNdskflksdflk’);
    </noscript>

    soula
    Participant
    Post count: 2

    Was this issue resolved? I began using Avada privacy message and now google analytics are not appearing. I’ve tested the site and consented but still no analytics.
    Help!
    pain-train.com.au

    zolikai
    Participant
    Post count: 1

    How does user manage their consent? How can I clear consent to show bar again?

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.