Avada Forums Community Forum Event Calendar pagination: Next & Previous not loading events

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • malymarketing
    Participant
    Post count: 16

    Events initially load as expected, but when a user clicks “Next Events” the next events don’t fully load, only one. If I refresh the page, then the events load. Same thing happens if I then click “Next Events” or “Past Events”.

    I disabled all plugins and the same thing happened. I then switched to the Twenty Twenty theme and the issue went away. I re-enabled Avada and the issue was back again, so clearly there’s an issue with the theme and a conflict with Events Calendar.

    Anyone else having this issue?

    See the issue here: https://nebraskalanddays.com/events/

    Scroll down, click Next Events, only one loads. Refresh, then the rest of them show up.

    malymarketing
    Participant
    Post count: 16

    I’m waiting to hear back from ThemeFusion support on a ticket I submitted, but I can verify that this issue is happening on all my Avada 6.2.1 sites that are using the Events Calendar… it is NOT happening on a site that is still running Avada 6.1.2.

    Jetxpert-Envato
    Blocked
    Post count: 339

    Yep, same problem here. Reported a while back, but still no answer/solution.

    Click here: https://theme-fusion.com/forums/topic/avada-6-2-broke-events-calendar-pro-v4-7-9-up/#post-707851

    I know Avada is busy working on other, more important issues, but hopefully, they’ll tackle this one soon.

    One of my first recommendations is to “un-marry” Events Calendar from Avada. They shouldn’t be embedding other plugins into their theme. It potentially creates downstream issues, like this one.

    Cheers!

    malymarketing
    Participant
    Post count: 16

    Not getting much in the way of a response from Avada support other than acknowledgement that they can see the issue. I went ahead and reverted back to Avada 6.1.2… not ideal, but I don’t have other options at this point. So the link above no longer shows the issue, but not because of some fix from Theme Fusion.

    If I hear back from them I’ll post their response here.

    malymarketing
    Participant
    Post count: 16

    Theme Fusion support has fixed the issue on a staging site for me after I gave them access, but they didn’t tell me what they did to fix it. I’m trying to get that info and will post it here if/when that happens. Hopefully there’s a patch forthcoming.

    malymarketing
    Participant
    Post count: 16

    The issue is with the new template builder. There’s a file called “class-fusion-template-builder.php” here: /plugins/fusion-builder/inc/ … that file was the issue.

    Theme Fusion support replaced it with a new one on my site. I’m assuming a patch is coming soon, but don’t know for sure.

    I actually got this information from the Events Calendar developers. I’d asked them about the issue I was experiencing and they got the info from Theme Fusion, then they passed on the corrected file to me. I can’t say for sure why Theme Fusion didn’t share the fix with me, but maybe it’s policy to just hold off on stuff like that until an official patch is ready.

    Anyway, I’d expect a patch soon.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.