Avada Forums Community Forum Deactivate Classic Editor

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • Monkette
    Participant
    Post count: 1

    Is it possible to deactivate the classic editor in the Avada Theme, so that the block editor is the default editor? Currently, every page and post defaults to the classic editor when I click “edit page” from the admin bar at the top of the page, even pages I created with the block editor. Additionally, there is no option to switch between block/classic editor in the page edit screen, like there is in other WordPress themes. This means that in order to edit an existing block editor page/post, I need go to the Pages list in the admin area, find the page, hover over the title, and click “Gutenberg Editor.” This is a lot of steps when you have multiple pages/posts to edit. The multiple editors is also confusing to clients who are new to WordPress.

    I understand that disabling the Fusion Builder on a post type will make the block editor the default editor, but I use the page builder on some pages and posts, so I need to keep it available as an option.

    So is there a way to completely deactivate the classic editor in the Avada theme, or at the very least, to make the block editor the default editor?

    Thanks for input.

    HolyTrinity
    Participant
    Post count: 3

    Hi

    I’m having the same issue, did you find a solution to this?

    Kind regards

    Ammar. S
    Keymaster
    Post count: 2546

    Hello There

    You can not completely disable the Classic editor as its required with Avada Builder too, this can happen if you completely want to switch to Gutenberg, however if you want to use both editors you need to manually switch there for sure.

    Thanks

    -Ammar

    HolyTrinity
    Participant
    Post count: 3

    The issue is, when I edit a page and click switch to block editor, it doesn’t switch. It always stays on classic editor.

    alyamanalhayekdesign
    Participant
    Post count: 3

    How is there still no fix to this? I have the same issue.

    hibiscusmoon
    Participant
    Post count: 1

    Two years in and still no solution to this? There should be a simple option to make the Gutenberg/Block Editor the default editor. In another forum post, it appears that the Fusion Builder has this option, but not the Avada theme itself?

    Larry D.
    Participant
    Post count: 4

    I love the Avada theme. But for some pages, I use the Gutenberg editor because the UI is more approachable for novice users. If I create a page with the “Gutenberg Editor”, I expect that “Edit Page” on the front end will open it with that editor. Currently with Avada V7.8.2, even with “Builder Auto Activation” set to “Off” in “Avada Builder Options”, if I click “Edit Page” on a Gutenberg Editor page, it still opens in Avada Builder. This seems like a bug to me.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.