Home Forums Community Forum Contact Us Menu Modal only working on home page

Tagged: ,

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • goannawebsites
    Participant
    Post count: 30

    I have an interesting issue that has me stumped…

    i have created a custom menu link for Contact Us that displays a modal with a phone number on it. However, it only works when user is on the website home page…it will not work on any other page.

    any ideas on why?

    EDIT…I have realised that one must manually add the modal to each page/post/etc. If this is a global element, shouldnt it automatically work on any page when menu is clicked? If not, how may i make it do this without having to manually add the modal to every single page or post?

    goannawebsites
    Participant
    Post count: 30

    Ah i see, we need to add the modal to a text widget in the footer.
    Problem solved with the exception of one major issue…what happens if for custom reasons i have had to remove the footer from all posts?

    What now?

    yelenavakker
    Participant
    Post count: 2

    Hi, have the same issue here. I have an extra modal menu for single posts that lead back to a one-page-scroll main page modal sections. It doesnt work on mobile. Sticky header is turned off. Tried on safari and chrome.

    yelenavakker
    Participant
    Post count: 2

    Found the problem. needed just to attach the mobile menu to the single post menu with a checkmark.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.