Avada Forums Community Forum Contact form template does not send email

Tagged: , ,

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • alanwbaker
    Participant
    Post count: 2

    I followed Avada’s instructions to use the contact form template.

    I created page https://europeanlc.es/contact-page-template/ using the sidebar’s Contact Template option and I specified my gmail account as the sender email address.

    When I test the form, it replies that the “email was successfully sent”, but none arrives. I’ve tried multiple email addresses and checked their spam folders. Any suggestions?

    Alan

    revans0636
    Participant
    Post count: 69

    Scroll down the form page to the Avada Form Options, and MAKE SURE you’ve set up where to send the email (Notifications tab). Also, check you have 2 notifications configured (2nd notification as a fallback when testing)

    Avada counts form output sent to your DB as email sent (when viewing the success variable on your page with the form). Add the notification, and I’d bet your good to go.

    If not, check w/your host and your MX settings. Their sendmail filter may be blocking form email output.

    If neither of the above, submit a support ticket and the Avada Support Team will get you sorted.

    Ray

    Ammar. S
    Keymaster
    Post count: 2234

    Hello @revans0636

    Thanks for helping a fellow community member 🙂

    Have a good day!

    -Ammar

    alanwbaker
    Participant
    Post count: 2

    Thank you, Ray. Alas, I’m stumped.

    Forms other than the contact form templates have a notification tab where one can specify multiple recipients, but the contact form template has no Notifications tab–it relies on the Email Address field in the Global Options. And I’ve tried both a gmail address and an xxx@domainname.com address there with no email sent in either case.

    I’ve also tried other (non-contact form template) forms, but nothing is sent from them either. That’s why I was trying the contact form template–it’s Avada’s most bare-bones form.

    The domain has no MX record, which isn’t the best practice, but at least there should be no blocking.

    Any suggestions will be welcomed.

    Alan

    revans0636
    Participant
    Post count: 69

    NP at all… Avada forms have the same form function, but you have to get to it first.

    Let’s try this (I’d guess you need to enable the Avada Forms in Global Options so the forms display in the WP sidebar under the Avada header, and you can see the form options where you see the notifications tab.)

    From the WP dashboard, click WP>>Avada>>Options (that opens your Global Options page) Use the search function, just type in forms and click enter. This is where you’ll see the form options, Google reCAPTCHA, Search Form, and Post Types. Make sure the Avada Forms are TURNED ON (enabled), and then save the page settings.

    Go back to the WP dashboard, refresh the dashboard, then expand WP>>Avada and look for a new function – Forms.

    Click Forms and it takes you to the Avada Form Builder function to create a form or edit forms previously created… (if you import a FULL theme, it comes with the prebuilt forms OR you can do a partial import and just get those forms).

    OK, Scroll down and you’ll see a list of the Avada Forms you have. Click “edit” under the form name for the form you’re having send issues with. Scroll down the page, under the form builder window, and you’ll see a section called “Form Options”. That’s where you configure where you want the form output sent, and that “should” fix your Avada form output problem.

    That’s the easy fix. Avada has world-class support, so if you’re still stuck, I’d suggest you submit a support ticket and ask them to look.

    Ray


    @Ammar
    S – Same as the Community Forum members who helped me when I started years ago, just don’t drop into the forum as often or post. The current issue I’m working on with v7.8 had me reading every post in here, thought I might be able to help. 🙂

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.