Avada Forums Community Forum Contact Form 7 Flagging as Spam even after changing "From" email address

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • kstecker
    Participant
    Post count: 2

    Hello! 👋 My contact form used to be set up just fine but somewhere around March of this year, it stopped working. It’s totally my fault for not noticing sooner (I was in school), but now I am very stuck. I have spent a good amount of time on the Contact Form 7 website (as well as googling my issue), with no luck whatsoever.

    My problem: When you try and submit the contact form, an orange dialogue box pops up saying, “There was an error trying to send your message. Please try again later.” See: http://www.bethelhealth.center/contact-us/

    I have already changed the default “From” address from wordpress@bethelhealth.center to admin@bethelhealth.center but the emails are still being flagged as spam immediately and not being sent at all. Nothing shows up in the Flamingo plug-in anymore, either.

    I did a search of this forum, too, and didn’t find anything that fit what I am experiencing. I found one person saying that they removed the recaptcha info from the Avada Theme Options contact form section, which I copied with no change in results, unfortunately. I am the first to admit that I am not the greatest at searching on here so I apologize if this is a duplicate post.

    I also messed around with changing back to recaptcha 2 instead of 3. I even tried making a whole new contact form but that didn’t make a difference either.

    Edited to add: I also added a plug-in “WP Mail SMTP” that was supposed to help avoid emails being marked as spam but this did not solve the problem either.

    I tried submitting a support ticket through Avada but since it’s a plug-in issue, they said they couldn’t help and just referred me to a page that talked about changing the default email address (which I had already done before contacting them).

    I figured I would reach out here to see if anyone else has encountered similar issues with Contact Form 7 because I don’t know what else could be wrong. Any insights that you might have would be greatly appreciated! (edited to add link to my contact form)

    marklchaves
    Participant
    Post count: 873

    Hi,

    I see two main concerns in your thread.

    1. Getting the “There was an error trying to send your message. Please try again later.” error message. Confirmed. I was able to reproduce this on your site.
    2. If the contact form works, the emails are getting flagged as spam.

    Have you contacted your hosting provider about the first issue? If you don’t get anywhere with #1, you might want to try third-party non-plugin services. I’ve used Formcarry https://formcarry.com/ on my non-WordPress sites. I’m also evaluating Formspree https://formspree.io/ (more free options).

    For the second, have you tried these best practices yet?

    https://contactform7.com/best-practice-to-set-up-mail/

    Good luck!

    kstecker
    Participant
    Post count: 2

    Thank you for your reply!

    I contacted my webhost and they confirmed that the site is set up to send and receive emails on the email addresses I listed originally. They also looked around and said everything seemed to be set up correctly and that it was not an issue they could help with due to it being a “wordpress issue.”

    I should have been a bit more clear on my original post – I did go through all of the things listed on the best practices page already. Sadly, they did not help me.

    Any other ideas?

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.