Avada Forums Community Forum Centering Portfolio Images (When Height > Width)

Tagged: 

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • brandonpkelly1
    Participant
    Post count: 2

    Greetings,

    How can I center the images in my portfolio grid view? (http://kellywm.com/projects/)

    All of the images are 380×400, so they are not squared. They are automatically aligned to the left, which looks a little unprofessional.

    Before I add all of my projects to this page, I want to fix this small issue.

    HKIQ
    Participant
    Post count: 1

    Hello Brandon!
    Did you get an answer already? I have the same problem…
    Greets, Kathi

    TrellisCompany
    Participant
    Post count: 1

    I’m in the same situation! Would really like to find a solution for this. Anyone?

    CoryOBrien
    Participant
    Post count: 1

    In case someone else runs into this same issue, here’s the fix I received from Avada:

    Add the following CSS to your custom CSS by going to WP-Admin Dashboard → Avada → Theme Options → Custom CSS and save it:

    .fusion-gallery-image {
    text-align: center !important;
    }

    cboylcd_helen
    Participant
    Post count: 1

    Hello.
    I would like to center the featured image in the portfolio. We don’t use bigger pictures because a lot of them are low res.How can I do this? I have tried a lot of CSS attributes, but unsuccessfully.
    Thank you.
    Best regards
    helen

    jberg1
    Participant
    Post count: 5

    This CSS seems to do the trick for me (using a Portfolio Element set to Grid layout). And looks to work fine on mobile too. However, you need to give the grid element a CSS class (ex. grid-container) to set text alignment.

    
    .grid-container {
    	text-align:center;
    }
    .grid-container .fusion-portfolio-post {
    	display:inline-block !important;
    	position:relative !important;
    	top:auto !important;
    	left:auto !important;
    	float:none !important;
    }
    

    Forgive the heavy handed “!important”.
    Hope it helps.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.