Avada Forums Community Forum Can't turn Comments on for blog posts

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • VeeZee
    Participant
    Post count: 14

    Hi,
    The setting for Comments is set to On for single blog post pages. But the meta info displays “Comments Off” and there’s no Comment box on the single post page.

    Each page (in edit view) shows that Comments are on.

    A web developer set up the site and made a few customizations through the Custom CSS element but there’s nothing about Comments in that code.

    Any ideas about why this is happening? Or where else to look for code that’s over-riding the standard elements?

    julieullery
    Participant
    Post count: 1

    I am having this same problem. Have tried everything.

    Kristin
    Participant
    Post count: 4

    Go into a post, scroll all the way up on the screen. On the top right you’ll see “Screen Options”.
    Click this, open it up and you’ll see a bunch of checkboxes. Make sure the checkbox is checked for Comments.

    bigpicturecommunication
    Participant
    Post count: 9

    Hi Kristin,
    That allows you to add comments in the back end, but doesn’t allow subscribers (or anyone) to leave a comment on the post (front end.)

    Anyone else solve this?

    Thanks in advance!
    j.

    Ammar. S
    Keymaster
    Post count: 2546

    Hello @bigpicturecommunication.

    Please make sure that you have them enabled from WP Dashboard > Settings > Discussion Tab by clicking here => https://share.getcloudapp.com/z8uxPP9n

    Thanks

    -Ammar

    bigpicturecommunication
    Participant
    Post count: 9

    Hi Ammar,

    Yes, I already have that setting turned on.

    I found that the only was I can get comments to show up is to disable Fusion Builder for posts (under Fusion Builder settings) and then go into the post settings in the Guttenberg interface… Document > Discussion > “Allow Comments”

    There seems to be no such option to “allow comments” in the Avada / Fusion Builder interface, and by default, comments are turned off. If I have fusion builder turned on for posts and make a new post (even if default editor) it won’t have comments enabled. (Under Fusion Page Options > Post, there is the option to “show comments” but that’s not the same as “allow comments.”)

    Is there perhaps a theme option or fusion builder setting that I haven’t found?

    Thanks for your help!
    Jason

    Adrian_Ellis_UK
    Participant
    Post count: 2

    I wasn’t able to turn on comments for static (normal) pages until I went to Avada – Theme Options – Extras – Miscellaneous and turned Comments on Pages to On.

    There’s nothing like putting a key option in an area marked ‘Extras – Miscellaneous’ 😉

    kranftle
    Participant
    Post count: 1

    Kristen mentioned the “screen options” solution, but she identified the wrong check box. To have the comment box visible on posts, you need to make sure that the “Discussion” box is checked in screen options, and then you’ll be able to turn on discussions from within the AVADA post editor.

    calonso23
    Participant
    Post count: 1

    Going to “Avada – Theme Options – Extras – Miscellaneous” and turning Comments on Pages to On is what avada users are not aware of, and for me was the final step (and time consuming one) to get my comments on finally.

    Ruson
    Participant
    Post count: 2

    Thank you!

    socialconcept
    Participant
    Post count: 1

    I had the same issue and found the clue on the global datas setting of the WordPress.
    On the comments section, you’re free to disallow comments x days after the publication.
    If you do so, you will encounter a comments closed advert.

    neovora
    Participant
    Post count: 3

    My issue was that I had created Custom Post Types, and at the very bottom in the “Supports” section, I hadn’t checked the “Comments” box. After adding that support, I went into an existing post, and the “Comments” section showed and was un-checked. So, by following socialconcept’s instructions above, I’ve unchecked the “Disallow comments after X days” and now when creating new posts (both blog and custom post types), the “Comments” section is there, and allowed.

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.