Avada Forums Community Forum Avada Not Detecting Server Settings

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • Jetxpert-Envato
    Blocked
    Post count: 339

    Avada’s System Status “Server Settings” is displaying erroneous information.

    Specifically, Avada is not detecting the actual values for “PHP Time Limit” and “Max Upload Size” as established by our host. Click here: http://prntscr.com/p9hlrp

    The host has set up these values as:

    PHP Time Limit (Max Execution Time) = 120
    Max Upload Size (Upload Max Filesize) = 256M

    Click here: http://prntscr.com/p9ho5m

    What is going on? Why are these values not being properly “read”?

    Any help you can provide would be appreciated. Cheers!

    Jetxpert-Envato
    Blocked
    Post count: 339

    Update:

    Was informed by Avada Support that PHP settings are read from the wp-config.php file and not from the usual php.ini file. Why? All other themes and plugins use the php.ini file.

    Avada: Kindly review and fix this at next revision. This is NOT the norm. If so, kindly explain or substantiate your approach.

    Thank you!

    Jetxpert-Envato
    Blocked
    Post count: 339

    Update (Temporary Fix):

    A temporary fix has been found. We added the following line to our wp-config.php file:

    set_time_limit(300);

    Avada’s Server Environment dashboard is now showing the proper Max Execution Time of 300 (instead of Zero).

    The big question is why is Avada not reading the same value from our php.ini file? It’s reading all values except the Max Execution Time (Click here: http://prntscr.com/qk53f2). When we delete the above line from our wp-config.php file, Max Execution Time drops to Zero (0).

    Conclusion: Avada code needs to be fixed to read all php limit values from the php.ini file.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.