Avada Forums Community Forum Avada Layout Conditions not working

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • bvansambeek
    Participant
    Post count: 5

    Hello,

    I am having some trouble assigning layout conditions to display a proper custom layout for a WooCommerce product.
    This is what I did:
    – Made a new product in Woocommerce and added a feature image of a webcam.
    – Avada Layout Builder -> Create New layout
    – In new layout select new content and create new section.
    – edit section to add some text “hello this is new layout section”
    – Manage conditions and selected new product.

    If i now go to the permalink of the product. then I do not see the custom layout.
    I think I had this problem before, but cannot remember the solution and cannot find it.
    Does anybody know what kind of step I am missing?
    FYI, I deactivated cache plugin: WP Rocket, for debugging and opened the product permalink in a incognito browser

    bvansambeek
    Participant
    Post count: 5

    I notice that if I go to WordPress – Products – All products
    and click “Avada Live” for an already working product, I mean that has a customized layout, that I see the following message if I go to Page Options – Layout: “This Product is currently using a custom Content Layout Section.”
    The new product as described above does not have this…
    Maybe I need to refresh some database somewhere? Man, what am I missing here…

    bvansambeek
    Participant
    Post count: 5

    fixed the issue. I have the feeling the conditions are applied in order from left to right from top to down.
    For example I had:
    – Product 1 (custom layout worked)
    – Product 2 (custom layout worked)
    – custom header for all pages and all products
    – Product 3 (custom layout did not work)

    The custom layout for product 3 was not show, because product 3 used custom layout with the custom header, which did not have ‘content’ divined, showing the Woocommerce standard product layout.
    changing the custom header to not apply to all products fixed the issue, the cannot be changed.

    gbollen
    Participant
    Post count: 3

    I’m having a similar issue with a custom layout I created for my categories. It’s not using my custom layout and showing some default category page.

    telangston
    Participant
    Post count: 1

    Around the same date I posted and used a custom template that has been working for months. Went to add a new post using the SAME template and the template was not applied to the post. I restored everything to Feb 16 and was able to post as expected. Some recent update has broken something.

    lisa.ujifusa
    Participant
    Post count: 1

    Layout Conditions no longer work after updating Avada plugins. I’ve had a Layout and have assigned pages as yes or no to get the layout. Has worked fine for 4 months. Until I did a plugin update of Avada Builder and Avada Core. I have new pages that I marked with √ for yes or x for no, waited for the auto save feature to stop blinking. The layout does not show on the pages I had marked with √. When I go back into Layout Conditions, both the √ and the x marks are no longer there – as if I didn’t do anything. I’ve tried like 10 times. This means my mega menu doesn’t show.

    Ammar. S
    Keymaster
    Post count: 2546

    Hello @Lisa

    The layouts still work fine without any issues in our latest version of Avada that is 7.8.2 so if you are not seeing them working properly, please try reinstalling Avada Builder again once, also please check your console for any possible errors due to a 3rd party plugin(s)

    Thanks

    -Ammar

    Kevinvelocity
    Participant
    Post count: 2

    I have the same issue for my blog category’s now.
    Made a layout and selected the category page which should be designed as the layout but it is still showing the default layout.

    Kevin

    Fuad
    Participant
    Post count: 7

    Potential Solution:
    POLYLANG – multi language plugin was the one creating issues. After it was disabled all Custom Layouts worked as intended. I believe once you get this done you can re-activate your third party plugins

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.