Home Forums Community Forum Avada Form Not Sending Emails (GoDaddy Managed WordPress Hosting)

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • garrettschnitzler
    Post count: 1

    Hi All,
    I’ve been trying to use the Avada Form element on my site. While it formats wonderfully, and collects the entries that I submit, it does not send email.

    I’ve followed the instructions here: https://theme-fusion.com/documentation/avada/how-to/how-to-set-up-a-contact-page/#troubleshooting

    The WP Mail SMTP plugin sends test emails successfully through to my email (Hosted by GoDaddy through Microsoft Exchange), however, the Avada Form still does not send the completed entries to my email (yes I’ve checked the junk)

    The settings that GoDaddy has provided me with to enter into the WP Mail SMTP plugin are the following:


    Port: 25
    SMTP Authentication: False or none
    SSL or Secure Connection: None/false

    I have searched Theme-Fusion forums and GoDaddy support forums to no avail.

    ThemeFusion is saying that there is some error on the hosts part.

    GoDaddy is saying it must be an issue with the Avada Form since the plugin is working correctly and sending email with the settings GoDaddy has provided.

    Has anyone run into a similar issue that they resolved?

    Post count: 1

    I’ve had exactly the same issue across all websites, and different hosting providers.

    Please tell me there is a solve for this? It’s been a terrible issue lately, and clients are getting really upset.

    It used to work before, so I don’t know what’s changed.

    Ammar. S
    Post count: 1799

    Hello There

    Please try changing the email address to some other email address and check again, if the issue persists with every email you have checked please open a support ticket so our team can get back to you, both of you have a valid support account and should be able to open a support ticket without any issues.

    Click Here to Get Avada Support



Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.