Avada Forums Community Forum Avada 7.0.2 & WordPress 5.5 Issues

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts
  • Joe
    Participant
    Post count: 6

    I’ve just updated Avada to the latest version (7.0.2) as well as updating WordPress to 5.5 to begin testing them with our site to make sure all works. Well its a good job I did test it first, because it looks like WP 5.5 has brought about a whole host of problems related to the updating of the JQuery library bundled with WordPress. You can read more about this here Updating jQuery version shipped with WordPress.

    In terms of the issues in Avada, some of them can be resolved by installing the jQuery migration plugin WordPress have provided: Enable jQuery Migrate Helper. However, after installing this plugin you are greeted with a warning message about any plugins that are using deprecated jQuery files, and it looks like Fusion Builder is one of them.

    Jquery issues in WordPress 5.5

    I’ve seen a bunch of other posts about issues with fusion builder, so it may be that this is cause of it. I haven’t finished all of my testing yet, so can’t verify if the jQuery migrate plugin solves any of the issues, but as I said, it does highlight the deprecated jQuery file Avada is still using.

    (apologies if this double posts, I am having some weird issues posting.)

    Michael C
    Keymaster
    Post count: 532

    Hi Joe,

    This forum is for user to user interaction. If you want support please submit a ticket https://theme-fusion.com/support/submit-a-ticket/

    Regarding your report here, what exactly are the original issues you had? I am struggling to follow the chain of events with what you are saying. In particular the jQuery bundled with 5.5 did not change. The actual updating part was moved to 5.6 https://core.trac.wordpress.org/ticket/37110.

    So updating to 5.5 should not be changing that or creating errors. The builder should also continue to work without installing any extra plugin. Before WP 5.6 is released and JS (such as flagged by that plugin) will be updated.

    Thanks

    VesnaS
    Participant
    Post count: 1

    Hi! I also have a problem after I’ve installed the newest updates of WP and Avada today… – my home page just doesn’t show itself anymore. It’s a membership site, so there was only a full-page photo and login form on the homepage. Now, it is just a white page.. no login form, no photo.

    I hope that developers will give us some patches soon.

    Regards!

    Michael C
    Keymaster
    Post count: 532

    Hi VesnaS,

    Without more information it would be impossible to help you. Additionally the chances of this being relevant to what has been posted in the original message of this thread is very small. If you want help then please create your own thread and provide details on the problem. Also do the standard checks:
    – Disable other plugins
    – Disable child theme if active
    – Double check Avada Core, Avada Builder are up-to-date
    – Turn on WP_DEBUG and check for errors
    – Check console for JS errors

    Thanks

    jsteckler
    Participant
    Post count: 14

    @michael-c

    I’m pretty sure this is the root of the issue:

    /plugins/fusion-builder/js/fusion-builder.js: jQuery.fn.load() is deprecated

    That call appears around line 2380. I was able to resolve the issue through the following:

    Replace:

    e(window).load(function ()

    With:

    e(window).on(‘load’,function ()

    bjuliano
    Participant
    Post count: 1

    @jsteckler

    Thanks for your help with the replacement example.

    Between this example and the JQuery Migrate Helper plugin, I was able to get my site back to it’s normal text editing mode.

    Michael C
    Keymaster
    Post count: 532

    Hi jsteckler,

    That should only be necessary if something else is being changed – either by a plugin or custom code. On WP 5.5 that should not need changed because the jQuery version change did not ship with 5.5. Similarly the migrate plugin should not be needed at all unless it is a plugin causing a change which then requires it. This is what I already posted.

    So for issues such as yours and bjuliano there is still a lack of information regarding the root change.

    Thanks

    jsteckler
    Participant
    Post count: 14

    Sorry, @simaem, I tried to delete the post but I’m unable to do so myself. Please do feel free to delete on my behalf.

    In my case, the only other information I can provide at this time is that it wasn’t another plugin—as I ran into the same issue while everything but Avada’s plugins were activated—but, like you “already posted,” it very well could have been some other custom code necessitating the /fusion-builder.js adjustment.

    I’ll avoid offering personal solutions in the future so as not to cause any support-related confusion again. Sorry all.

    Michael C
    Keymaster
    Post count: 532

    Hi jsteckler,

    All good! I understand you were sharing your own experience and trying to be helpful. Just with general problems such as the builder not loading it can be any number of root cause. So one fix for all approach will often lead to separate knock-on problems for different people.

    Thanks

    Brand in Webdesign
    Participant
    Post count: 2

    Hi,

    I have a problem with widgets.
    If i go to widgets and i want to open a widget he dont opent, so i can’t change info in a widgets.
    is this a problem in WordPress or in Avada or both?

    genxer
    Participant
    Post count: 3

    Hi, Please try this Plugin

    I hope it is will help you. I’ve used it on different theme, it worked.

    Regards,
    Genxer

    Schaeffer
    Participant
    Post count: 3

    I am also having the same issue as @Joe. I am currently running WP version 5.5 and Avada 7.0.2 and on every page that I use the fusion page builder I am receiving a JQuery error:

    /wp-content/plugins/fusion-builder/js/fusion-builder.js: jQuery.fn.load() is deprecated

    I have installed the plugin jQuery Migrate Helper and that has seemed to fix most of the issues that I was encountering but I am hoping that Themefusion comes out with a patch so I don’t have to use that plugin moving forward.

    fibaby
    Participant
    Post count: 1

    I too am receiving the message – and I am up to date with wp 5.5 and Avada 7.0.2.
    /wp-content/plugins/fusion-builder/js/fusion-builder.js: jQuery.fn.load() is deprecated

    Brought my site to a grinding halt.
    But adding the jQuery Migrate Helper seemed to get it going again.

    Schaeffer
    Participant
    Post count: 3

    The deprecated load() function is being used still in js/fusion-builder.js and WordPress 5.5 removed jQuery Migrate which is a small library to emulate the missing methods so your old code still works.

    The load function was removed from jQuery in the 3.0 release. Since WordPress upgraded the jQuery core version in 5.5 and removed jQuery Migrate any plugins or themes using the deprecated live(), load(), etc will not work properly until the plugin author(s) refactor the code to remove the deprecated functions.

    The solution to this is quite simple: replace

    $(window).load(function() {

    with

    $(window).on(‘load’, function() {

    https://jquery.com/upgrade-guide/3.0/#breaking-change-load-unload-and-error-removed

    The developers of jQuery decided that it was better to have a single on() function that can respond to all of the events rather than having separate functions for each event.

    sticknpoke
    Participant
    Post count: 3

    I am not a developer so im going to just post what I was told to post from my WP engine support who tried to help me….basically they said there is an issue with the new WordPress and the newest Avada theme. The way it’s showing up on my site is that people do not get an confirmation page from me, nor emails from me and the contact form doenst work. Basically it freezes up whenever the site is meant to send an email to anyone. It results in frustrated customers and multiple orders, so I have rolled it back.
    I’ve tried to get a new SMPT plugin and all that but does not fix it. Anyhow, I am running an old wordpress because updating causes these issues.

    Please alert me when this issue is fixed and updating is safe! (or if you have another suggestion that’s great too).

    Thanks!

Viewing 15 posts - 1 through 15 (of 19 total)
  • You must be logged in to reply to this topic.