Updating Avada from Older Versions

Updating Avada from Older Versions

08/06/2018

Why you should update your theme and plugins regularly

A major reason for keeping your WordPress theme and plugins up-to-date is for security purposes. Keeping your site updated ensures you have the latest security fixes and that your site is following the latest security best practices available. For more information on security in WordPress, you can read about it in the Codex here.

If you've fallen behind on updates or you're taking over a new project that hasn't been updated in a while, this post will guide you in updating from older versions of Avada up to the latest.

Pre-Update Tips

  • Before processing any update, be sure to take a full site and database backup. That will ensure you’re able to revert to a working point in your site if anything unexpected happens.
  • It's also very important that you ensure your server limits are at the required minimums for the update/theme install to complete seamlessly. Click here for more information.
  • When updating from old versions of Avada, we recommend a staggered update path. Below we'll guide you through one major theme update at a time. This will make the process as smooth as possible for you. At the end of each section, there will be a link to download each theme version required for the update path.
  • Check our detailed Important Update Information archive to find noteworthy details for any updates between your current version and the latest Avada version. Click here to view the Important Update Information Archive.

Recommended Update Path:

With each new Avada update comes a set of new options, features and code improvements. Click on the version path that matches your current Avada version for detailed instructions

  • Avada 3.9 and older: If you're below version 3.9, then you'll start with the steps in this section.
  • Avada 3.9.X: If you're at version 3.9.X, then you'll start with the steps in this section.
  • Avada 4.0.X: If you're at version 4.0.X, then you'll start with the steps in this section.

Updating From Avada 3.9 And Older

Regardless of what version of Avada you have currently, if it's before Avada 3.9, then 3.9.4 should be your first stage in the update. For info on what's new to this theme version, click here!

  • If you haven't checked the Pre Update Tips section from above yet, click here for that important information.

If you’re updating from an Avada version before Avada 3.8 and you have custom CSS, you’ll need to check your custom CSS after the update due to a CSS refactor in Avada 3.8. Because of the refactor, your custom CSS classes may also need updated so they match the new classes used in Avada.

  • For detailed information on the 3.8 update, please Click here
  • For information on custom CSS in Avada please click here.

If you have no customizations or custom CSS in your theme, then the update to 3.9.4 should be routine. For standard update information, please see our guide here.

Note: Since you'll be updating with the Avada 3.9.4 files manually, only method #2 and #3 will work from that post.

After the update has completed, then clear your cache completely and check your site over to see if everything is working well. Since this is still an older version of Avada, it's recommended that you have your plugins disabled, aside from the Fusion Core plugin, while testing your site. This is to ensure any issues you see aren't related to a plugin conflict. The primary goal here is to just ensure that the theme styling is how it should be, then on to the next update.

Updating From Avada 3.9.X

When updating from Avada 3.9.X, your next stage in the update chain will be 4.0.3. If you're not at 3.9.X yet, follow the steps in the section above, before proceeding. For info on what's new to this theme version, click here!

If you haven't checked the Pre-update Tips section, click here for that important information.

In Avada 4.0.X the most notable change will be the migration from the old Avada Theme Options to the new Avada Theme Options.

IMPORTANT NOTICE: Before processing this update, be sure to take a full site and database backup. That will ensure you're able to revert to a working point in your site if anything unexpected happens.

To be sure the Theme Options migration completes correctly, you'll want to double check your Avada System Status page and increase any limits that are showing a red notice (with the exception of max_input_vars as that will have no effect on the migration). Please see here for information on increasing your server limits and here for information on server requirements in Avada.

As an extra precaution, it's recommended that you disable all non-Avada plugins (with the exception of WPML if in use), while the migration is being processed. This will ensure your Theme Options migration isn't hindered by a plugin conflict.

If you get get trapped in the migration (e.g. The migration steps are endlessly repeating, or are frozen.), then you can correct this with FTP access. If you didn't disable your plugins, then you may have a plugin conflict. You can fix this by changing the name of the wp-content/plugins directory to something else temporarily. (e.g. wp-content/plugins-dis) That will disable all the plugins and allow the migration to complete.

SPECIAL NOTE FOR WPML USERS: If you're using WPML, you'll want to be sure you're updated to the latest version of the plugin so the migration completes for all languages. There was a conflict in a previous WPML version which caused the Theme Options migration to get stuck midway through. This was fixed in their plugin, so using the current version will ensure you're in the clear.

Updating From Avada 4.0.X

If your current theme version is Avada 4.0.X, then your next stage in the update will be the latest version of Avada. This will include the conversion of your shortcodes from the old Avada page builder to the new Fusion Builder which was introduced in Avada 5.0. For info on what's new to Avada 5.0 click here.

If you're not at 4.0.X yet, please reference the appropriate section above for your current theme version, before proceeding.

If you haven't checked the Pre Update Tips section from above yet, click here for that important information.

IMPORTANT NOTICE: Before processing this update, be sure to take a full site and database backup. That will ensure you're able to revert to a working point in your site if anything unexpected happens.

Since the new Fusion Builder uses different shortcodes, any shortcodes generated by the Avada page builder prior to Avada 5.0 will not render elements and will only appear as plain text. There's an automated conversion process which will occur to update your content to the new shortcode syntax.

Areas that are automatically converted by Avada include: pages, blog posts, portfolios, WooCommerce product content and excerpts, widgets, theme options, Fusion Sliders, Revolution Sliders and LayerSliders.

Note: It will not automatically convert shortcodes from any custom post types you may have or from other plugin's custom post types that may be in use on your site. For information on how to manually include those post types in the Avada conversion process, click here to view our guide.

If after the update, your site is showing all shortcodes on the front end of the website, the conversion may not have completed correctly. Although it looks like a serious problem, it’s normally just due to low server limits causing the update process to be truncated. To fix this, you can manually trigger the shortcode conversion again at the top of the System Status page. If that doesn't correct the issue, double check that the Fusion Builder plugin is installed and activated.

How To Update To The Latest Avada

Getting Additional Help When Needed

If you have trouble with the update and you need additional help, please submit a support ticket to our support center and we'll check into it ASAP. Please fill out all the requested fields in the ticket submission form to avoid delays.

  • To register an account and register your purchase to access theme support, please click here
  • If you already have registered and need assistance please create your support ticket here
  • Purchases made before September 1st, 2015 are eligible for our Avada Grandfathered support. More information on Grandfathered support can be found here
  • If your support account has expired, you can find information on renewing that here

Recent Posts

Recent Tweets

For privacy reasons Twitter needs your permission to be loaded. For more details, please see our Privacy Policy.
I Accept